bsd.apache.mk Malformed conditional when APACHE_VERSION defined

olli hauer ohauer at gmx.de
Sun Feb 2 10:51:37 UTC 2014


On 2014-02-02 10:11, Dewayne Geraghty wrote:
> I filed a PR against textproc/htdig which should really be against the
> ports systems.
> 
> Would someone be kind enough to advise the current method to specify the
> apache version.   In ports.conf, I currently use
> USE_APACHE=22 | APACHE_VERSION=22
> to specify the required version of apache for:
> textproc/htdig
> www/mod_security
> lang/php5
> 
> I believe this PR 
> 
> http://www.freebsd.org/cgi/query-pr.cgi?pr=186364
> 
> which probably should be routed to the ports system, and not textproc/htdig
> 
> The error is:
> cd /usr/ports/textproc/htdig && make  -V UNIQUENAME
> "/usr/ports/Mk/bsd.apache.mk", line 306: warning: String comparison
> operator should be either == or !=
> "/usr/ports/Mk/bsd.apache.mk", line 306: Malformed conditional
> (!empty(_APACHE_VERSION_MINIMUM) && (${_APACHE_VERSION} <
> ${_APACHE_VERSION_MINIMUM}))
> "/usr/ports/Mk/bsd.port.mk", line 6603: if-less endif
> make: fatal errors encountered -- cannot continue
> 
> which goes away if APACHE_VERSION isn't used, eg.
> cd /usr/ports/textproc/htdig && make __MAKE_CONF=/dev/null -V UNIQUENAME
> htdig
> 

Hi Dewayne,

APACHE_VERSION is a read only variable in case a port needs to know the
installed / default Apache version -> do not set this variable!

In case you want to specify a default apache use in etc/make.conf for example
 APACHE_PORT=www/apache22

See lines 12 - 25 in Mk/bsd.apache.mk


-- 
Regards,
olli


More information about the freebsd-ports mailing list