Compiling sguil-server on Release 9.2 i386

s_gammons at s_gammons at
Sat Oct 19 13:15:07 UTC 2013

> Your error is line 46 where it tries to run, "cd
> ${PORTSDIR}/databases/mysqltcl && ${MAKE} -V PORTVERSION".
> While running "make" on another port is horrible, it's not the 
> actually
> problem either.
> First, make sure ports tree is up to date.
> Then run, "cd /usr/ports/databases/mysqltcl && make-V PORTVERSION"
> And see if you have an error message.
> If not, try sguil-server again after restoring it.

I started from scratch.  Reinstalled the OS, updated the ports tree then 
changed to /usr/ports/databases/mysqltcl and ran "make -V PORTVERSION" 
That resulted in 3.052 being returned.  Changing to 
/usr/ports/security/sguil-server and running "make install" starts the 
build process and I get the prompt to build with MYSQL.  When I select 
MYSQL option, it bombs with the same error.

What I tried before was install all of the depends with portmaster, then 
tried to install sguil-server by going to 
/usr/ports/security/sguil-server and running "make install".  I got the 
same unassociated shell command error.  Modifying the Makefile by 
removing the M allowed the build process to continue.  I had to stop the 
build process before it completed since that machine was getting really 
hot from being run so hard all day.  So, I don't know if the build would 
have completed. I can try it again, but I'd like to find out what's 
causing this to fail.

Any other ideas?


More information about the freebsd-ports mailing list