Compiling sguil-server on Release 9.2 i386

John Marino at
Sat Oct 19 14:02:17 UTC 2013

On 10/19/2013 15:15, s_gammons at wrote:

> I started from scratch.  Reinstalled the OS, updated the ports tree then
> changed to /usr/ports/databases/mysqltcl and ran "make -V PORTVERSION"
> That resulted in 3.052 being returned.  Changing to
> /usr/ports/security/sguil-server and running "make install" starts the
> build process and I get the prompt to build with MYSQL.  When I select
> MYSQL option, it bombs with the same error.
> What I tried before was install all of the depends with portmaster, then
> tried to install sguil-server by going to
> /usr/ports/security/sguil-server and running "make install".  I got the
> same unassociated shell command error.  Modifying the Makefile by
> removing the M allowed the build process to continue.  I had to stop the
> build process before it completed since that machine was getting really
> hot from being run so hard all day.  So, I don't know if the build would
> have completed. I can try it again, but I'd like to find out what's
> causing this to fail.
> Any other ideas?

"other ideas"?
The line I mentioned is the one returning the error.  That is still
true, it's not getting "3.052" when building security/sguil-server.

You need to forget about removing the "M", that's a red herring.  By
removing the "M", you skipped the line that is failing, but that also
means MYSQL isn't built in either.

If you just want the thing to build (and not care if that sguil-server
makefile is busted), then try this:
1) Remove line 46 completely.
2) On line 47, replace "${MYSQLTCL_VER}" with "3.052"

I feel that the makefile could be reworked to avoid calling make on
databases/mysqltcl in a number of different ways, but that is for the
maintainer to decide (i.e. open a PR so it's fixed permanently).


More information about the freebsd-ports mailing list