Can't build Xorg --> make failed for ports-mgmt/pkg

Miguel Clara miguelmclara at
Wed Jun 12 23:21:49 UTC 2013

On Wed, Jun 12, 2013 at 10:31 PM, Miguel Clara <miguelmclara at> wrote:
> On Wed, Jun 12, 2013 at 9:53 PM, Chris Rees <crees at> wrote:
>> On 12 June 2013 19:34,  <miguelmclara at> wrote:
>>> I'm attempting to install kde4 in FreeBSD 10-current, after 3 days
>>> dealing with some dependency issues I was able to install kde4  with
>>> portmaster...
>>> Before kde  already installed Xorg, but I get a "green" and sometime
>>> "purple"screen when X starts, the log pointed me to this problem:
>>> However when trying to rebuild Xorg with portmaster it stops on "pkg"
>>> with the following error:
>>> ====================
>>> --- pkg-static ---
>>> gcc -O2 -pipe -I/usr/local/include -fno-strict-aliasing
>>> -I/data/ports/ports-mgmt/pkg/work/pkg-1.0.12/pkg-static/../libpkg
>>> -std=gnu99 -fstack-protector -Wsystem-headers -Werror -Wall
>>> -Wno-format-y2k -W -Wno-unused-parameter -Wstrict-prototypes
>>> -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual
>>> -Wwrite-strings -Wswitch -Wshadow -Wunused-parameter -Wcast-align
>>> -Wchar-subscripts -Winline -Wnested-externs -Wredundant-decls
>>> -Wold-style-definition -Wno-pointer-sign  -L/usr/local/lib -static -o
>>> pkg-static add.o audit.o autoremove.o backup.o check.o clean.o
>>> create.o delete.o event.o info.o install.o main.o progressmeter.o
>>> query.o register.o repo.o rquery.o update.o upgrade.o search.o set.o
>>> shlib.o updating.o utils.o version.o which.o fetch.o shell.o stats.o
>>> -L/data/ports/ports-mgmt/pkg/work/pkg-1.0.12/pkg-static/../libpkg
>>> -lpkg  -larchive  -lutil  -lpthread  -lsbuf  -lfetch  -lssl  -lcrypto
>>> -lmd  -lz  -lbz2  -llzma
>>> -L/data/ports/ports-mgmt/pkg/work/pkg-1.0.12/pkg-static/../external/sqlite
>>> -lbsdyml -lsqlite3  -larchive  -lsbuf  -lfetch  -lpthread  -lelf
>>> -lssl  -lcrypto  -lmd  -lz  -lbz2  -llzma -ledit  -lncursesw -ljail
>>> /usr/local/lib/libpkg.a(pkgdb.o): In function `pkgdb_cmd':
>>> pkgdb.c:(.text+0x947f): undefined reference to `sqlite3_shell'
>>> *** [pkg-static] Error code 1
>>> make: stopped in /data/ports/ports-mgmt/pkg/work/pkg-1.0.12/pkg-static
>>> 1 error
>>> =============
>>> Is anyone else having this problem? Or has anyone build/installed
>>> xorg+kde4 from ports on current with sucess?
>> You possibly have an out-of-date wrkdir for pkg.
>> Try removing all the work/ directories;
>> # echo `make -f /usr/share/mk/
>> -VWRKDIRPREFIX`/usr/ports/*/*/work | xargs rm -r
>> Chris
> Thanks for the hint, I've tried that but still get the error mentioned here:
> It seems that for some reason the email subject got an extra "/" and
> created a new thread :/

Acctually the error mentioned there is different and I'm not sure how
I got it since I can not repruduce it, perhaps in that case I did
forgot to clean work dirs!

Anyway I have no tried to rm the work dir, make deinstall, make clean
and when I do:

make all I get:
-lpthread  -lsbuf  -lfetch  -lssl  -lcrypto  -lmd  -lz  -lbz2  -llzma   -ljail
undefined reference to `sqlite3_shell'

I have really no idea why I'm getting this :|

More information about the freebsd-ports mailing list