[SOLVED] Re: Can't build Xorg --> make failed for ports-mgmt/pkg

Miguel Clara miguelmclara at gmail.com
Thu Jun 13 14:24:57 UTC 2013

I did a make deinstall removing pkg... make clean and made sure work
dir was gone!

Then I tried "pkg" command, because if its no installed i will ask you to do it!
I accepted the install of pkg-1.0.11

After this I tried portmaster -f x11/xorg, pkg was again mentioned for
update, and again it failed!

I cleaned dirs again rebooted...

Than I tried to rebuild just "libdrm" and not xorg, with portmaster
-f, pkg was mentioned again but this time the update worked and I'm
now with pkg-1.0.13

pkg info | grep pkg
pkg-1.0.13                     New generation package manager

I'm not exactly sure why it worked now and not before... The only
difference now is that I made a "make deinstall", I'm glad its
solved... still having issues with "xorg" but that is a totally
different discussion!

Thanks everyone for the replies

More information about the freebsd-ports mailing list