arts 1.5.10 deprecated

RW rwmaillists at googlemail.com
Mon Jun 10 22:40:54 UTC 2013


On Mon, 10 Jun 2013 16:43:14 -0400
Robert Huff wrote:

> 
> Matthias Apitz writes:
> 
> >  > 	An attempt to rebuild this brought a message saying the
> >  > port is deprecated due to dependency on qt3.
> >  > 	Considering I have at least a dozen ports listed as
> >  > dependencies - including gimp, sdl_*, and mplayer - what is the
> >  
> >  Btw: I do not see that mplayer depends on qt3 stuff:
> >  
> >  $ pkg_info -r mplayer-1.1.r20130308 | fgrep qt3
> >  
> >  > recommended replacement?
> >  
> >  In general, the answer will be: use qt4-* ports :-(
> 
> 	As soon as a) I know what the equivalent is and b) it compiles
> and runs.
> 	I am happy to know arts is an indirect dependency (probably
> thought the sdl_*) and mplayer /et al./ will hopefully continue to
> function. 
> 	Not happy I do not have the skill to disentangle this and know
> for sure.

Arts is an optional dependency of mplayer that's off by default. I
think that's generally the case outside of KDE3 ports. It's not used in
KDE4 at all.


More information about the freebsd-ports mailing list