pkgng upgrade options

Daniel Nebdal dnebdal at gmail.com
Tue Dec 3 17:40:26 UTC 2013


On Tue, Dec 3, 2013 at 11:54 AM, Beeblebrox <zaphod at berentweb.com> wrote:

> >> There should be some OPTONS_FILE_UNSET variables
> I just left those out and only posted those with " OPTIONS_FILE_SET"
>
> >>It's possible that the FreeBSD repo is before your local repo.
> >>To see the repository order use:  pkg -v -v
> Yes, the FreeBSD repo is listed first while myrepo is #2. I don't see how I
> can change the order though. Combining all repo info into a single file
> comes to mind; tried and it seems to break things.
>
> The unixODBC / libiodbc conflict is from these two: databases/php5-odbc  &
> databases/php5-pdo_odbc
> They both have "OPTIONS_FILE_SET+=IODBC" however, so should nat ask for
> unixODBC
>
> The most serious pkg conflict I am seeing is devel/py27-distribute vs.
> devel/py27-setuptools
> "pkg set -o devel/py27-distribute:devel/py27-setuptools" has no effect.
> Only
> emulators/virtualbox-ose is asking for devel/py-distribute.
>
>
>
> -----
> FreeBSD-11-current_amd64_root-on-zfs_RadeonKMS
>

This might be overly trivial, but ... is py27-setuptools already installed,
by chance? Can you try removing it?


--
Daniel Nebdal


More information about the freebsd-ports mailing list