emacs23 not working in terminal

Ashish SHUKLA ashish at FreeBSD.org
Mon Apr 8 16:34:03 UTC 2013

On Mon, 08 Apr 2013 12:14:33 +0200, Andrea Venturoli <ml at netfence.it> said:
> Hello.

> I'm a long time user of Emacs and I've got several different installations.
> Recently some of them started behaving: X11 version works fine, but
> running with -nw (or no X configured) results in keyboard not
> working. Pressing any key yields no result and emacs has to be
> "kill"ed externally.
> This happens regardless of how the box is accessed (local/ssh,
> Konsole/putty, etc...)

Are you able to reproduce it with: emacs -Q -nw ?

> I solved this on most installations with "portupgrade -Rf emacs", but
> I still have one box where this did not help.

You mean upgrading to Emacs24 fixed it ?

> Where should I start looking?

Start with truss(1)-ing the Emacs process.

Ashish SHUKLA      | GPG: F682 CDCC 39DC 0FEA E116  20B6 C746 CFA9 E74F A4B0
Sent from my Emacs
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20130408/8aef33fa/attachment.sig>

More information about the freebsd-ports mailing list