[CFT] Hadoop preliminary port

Bleakwiser traebarlow at gmail.com
Mon Feb 13 08:48:05 UTC 2012

I was able to find some better information on the patch command through
wikipeida, their article on it is really great.

However I'm still not clear on what files I'm supposed to download to be
running the patch on. I've dug around inside the .diff file with pico a bit
and it's rather cryptic. Lots of things are commented (I assume by +) and I
was also able to find some relevant man pages on 'patch' as opposed to 'man
diff' i was using earlier.

The correct command would be 'patch -p1 < hadoop-1.0.0.diff' not just
'patch -p1' w/o any other arguments, which tells the patch program to use
the directory structure inside the .diff file. But perhaps piping the
output of 'fetch' handles that all for me?

However, we are getting way ahead of ourselves here and the same thing can
be accomplished with different syntax. W/o having the correct software
apply the patch to there isn't much sense in running the command at all
anyway. Since I'm not familiar with the rather cryptic contents of .diff
files I've wasted a good half hour just looking through it's contents for
some clue as to exactly what I need to be downloading. Of course there is
always the try and fail technique, where I would just simply try each tbz
off the site and try and fail until it worked... for some reason I never
liked that method.

Thanks and again. I am defiantly not eleete enough to be helping test this
port so I'll leave it to those informed already on the list. I wouldn't
want to continue to waste anyone's time w/ trivial questions much less
waste hours and hours of my own time looking up syntax for nitche CLI
utilities so take care and good luck with the port. It's defiantly a
'killer app' so for BSD's sake I hope you folks get it.

And as promiced, the /facepalm of failure...

On Mon, Feb 13, 2012 at 2:27 AM, Matthew Seaman-2 [via FreeBSD] <
ml-node+s1045724n5478487h28 at n5.nabble.com> wrote:

> On 13/02/2012 07:57, Bleakwiser wrote:
> > Kidding right?
> >
> > patch -p1 isn't even mentioned in the man pages.....
> > And again, i've ran,
> >> > patch hadoop-1.0.0.diff
> > Nothing happens, just blank cursor.
> patch expects to read a diff file on its standard input, so the command
> you need to run is:
>    patch < hadoop-1.0.0.diff
> > For starters it isn't really clear what I'm even supposed to be applying
> > the patch to.
> The files to patch are determined from the content of the diff.
>         Cheers,
>         Matthew
> --
> Dr Matthew J Seaman MA, D.Phil.                   7 Priory Courtyard
>                                                   Flat 3
> PGP: http://www.infracaninophile.co.uk/pgpkey     Ramsgate
> JID: [hidden email] <http://user/SendEmail.jtp?type=node&node=5478487&i=0>              Kent, CT11 9PW
> *signature.asc* (275 bytes) Download Attachment<http://attachment/5478487/0/signature.asc>
> ------------------------------
>  If you reply to this email, your message will be added to the discussion
> below:
> http://freebsd.1045724.n5.nabble.com/CFT-Hadoop-preliminary-port-tp4677071p5478487.html
>  To unsubscribe from [CFT] Hadoop preliminary port, click here<http://freebsd.1045724.n5.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=4677071&code=dHJhZWJhcmxvd0BnbWFpbC5jb218NDY3NzA3MXwtMTM3NzMyMDgyNA==>
> .
> NAML<http://freebsd.1045724.n5.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>

Trae Barlow

View this message in context: http://freebsd.1045724.n5.nabble.com/CFT-Hadoop-preliminary-port-tp4677071p5478517.html
Sent from the freebsd-ports mailing list archive at Nabble.com.

More information about the freebsd-ports mailing list