pkg and portmaster: Downgrading ports? Why? portmaster messes up ...

O. Hartmann ohartman at
Tue Aug 7 09:31:22 UTC 2012

I tried to switch to the new tool pkg. I'm still installing my ports via
sources and compiling, but I appreciate the more stable dependency
tracking of pkg(ng).
Therefore, I patched, as reuqired and recommended, ports-mgmt/portmaster.

I performed a portmaster --check-depends after I got several warnings
and two very confusing (if not scaring) exclsuions and therefore rejections:

graphics/libGL and x11/nvidia-driver (which is in my case 304.32 and
works pretty well so far!), x11-server/xorg-server. They all install, so
the compalin of pkg/portmaster, files in the very same place. So I'm
stuck and I do not know, whether my ports collection is now corrupted by
this stubborn behaviour or not.

Mor scaring, performing a "portmaster --check-depends" ends up in this:

>>> Missing package dependencies were detected.
>>> Found 2 issue(s) in total with your package database.

The following packages will be installed:

        Installing pkg-config: 0.25_1
        Downgrading pciids: 20120711 -> 20120625
        Downgrading libdrm: 2.4.31_1 -> 2.4.17_1
        Installing libGL: 7.6.1
        Installing perl: 5.14.2_2
        Downgrading dbus: 1.4.14_3 -> 1.4.14_2
        Downgrading dri: 7.11.2_1,2 -> 7.6.1,2
        Downgrading pcre: 8.31 -> 8.30_2
        Downgrading python27: 2.7.3_3 -> 2.7.3_2
        Installing xorg-server: 1.7.7_5,1

The installation will require 40 MB more space

28 MB to be downloaded

Before I made the update towards pkg via pkg2ng, I updated everything
with portmaster as it worked in the old-fashion before. I have set
properly the knob WITH_NEW_X11 in /etc/make.conf. Now this new toolset
tries to donwgrade some of the ports - why? What happens here?

ports-mgmt/portmaster installs still the old fashioned style folders of
ports in /var/db/pkg. I thought ith the new scheme of pkg, everything is
going into a file based SQLite3 DB?

With each kernel update, I also need to update x11/nvidia-driver. I do
this by /etc/src.conf setting

PORTS_MODULES=          "x11/nvidia-driver"
PORTS_MODULES+=         "emulators/virtualbox-ose-kmod"

The nvidia driver now fails. How can I circumvent this nasty problem? Is
there a "brute force" knob.

Will ports-mgmt/portupgrade-devel heal those problems?

My OS is a most recent FBSD 10.0-CURRENT.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
Url :

More information about the freebsd-ports mailing list