xfce 4.8 upgrade errors.

Scott T. Hildreth shild at sbcglobal.net
Sat Mar 5 19:09:35 UTC 2011

On Sat, 2011-03-05 at 09:27 -0800, Charlie Kester wrote:
> On Fri 04 Mar 2011 at 18:23:47 PST Aryeh Friedman wrote:
> >I had to reinstall all my ports from scratch to fix this... for how to
> >do this safely see the last example of the man page for portmaster
> >
> >On Fri, Mar 4, 2011 at 9:07 PM, Scott T. Hildreth <shild at sbcglobal.net> wrote:
> >> I updated my server to 8.2 and then all my ports.  When compiling orage
> >> or trying to it failed with libical errors,
> >>
> >> In file included from ical-archive.c:56:
> >> /usr/local/include/libical/icalss.h:38:27: error: icalcomponent.h: No such file or directory
> >> /usr/local/include/libical/icalss.h:111:23: error: icalgauge.h: No such file or directory
> >> /usr/local/include/libical/icalss.h:282:21: error: icalset.h: No such file or directory
> >> /usr/local/include/libical/icalss.h:342:25: error: icalcluster.h: No such file or directory
> >>
> >>
> >> ...I cannot find a solution for this, is anyone else seeing this
> >> error. When they compile orage?
> The root cause of this problem seems to be that
> /usr/local/include/libical is not in the include path.  
> icalss.h includes these other header files without specifying the
> subdirectory.  I.e., it does the following:
> #include <icalcomponent.h>
> Since it's not on the include path, icalcomponent.h is reported as not
> found.
> Adding CFLAGS+=-I${LOCALBASE}/include/libical to the port Makefile fixes
> this.
> BTW, I haven't confirmed this yet, but the orage configure step seems to
> enable libical support if the library is found, overriding the WITH_ICAL
> option.  When I put the above CFLAGS line inside the if block for
> WITH_ICAL, and set the option to OFF, the build still failed with the
> same errors listed above.  It shouldn't have mattered whether or not my
> CFLAGS line was executed, because it shouldn't have been compiling any
> ical-related stuff. But it was. 

This worked, thank you.   

I also tried turning off the ical support in the config, but still had
the same problem.

> _______________________________________________
> freebsd-ports at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-ports
> To unsubscribe, send any mail to "freebsd-ports-unsubscribe at freebsd.org"

More information about the freebsd-ports mailing list