FreeBSD Port: zabbix-server-1.8.3,2

Jim Riggs ports at
Thu Oct 21 14:21:02 UTC 2010

On Oct 21, 2010, at 8:04 AM, Переклад Алексей wrote:

> I have multiple problems with net-mgmt/zabbix-server port on FreeBSD 8.1. First of all, it requires the netlibsnmp library version 1.6 while FreeBSD 8.1 uses version 2.0. I repaired that by creating symlink “” to

There must be something strange in your setup.  I just tried this in my 8.1 environment with a fresh install of zabbix-server and all of its dependencies.  It worked fine using

> Then  i could not compile zabbix-server for the same reason as described in PR  ports/150376. I avoided this error by “pkg_delete –f libexecinfo” then installING zabbix-server and then installinglibexecinfo again.

Did you try the patch in that PR?  I just sent a slightly updated one that makes it work with libexecinfo installed.

> But the saddest problem is that: after installing zabbix-server port i could not find its PHP frontend. I did “make extract” and found it in the port’s “frontend” directory, then I just copied the /php directory to the right place. But after doing all the installation procedures – like creating a database, creating a .conf file for frontend and logging into the web interface, I could not find some menu items in “Configuration”. Funny thing is that in FreeBSD 8.1 i386 everything was fine with the web interface, but in 8.1 amd64 i have no items like “Items”, “Triggers”, “Graphs” in “Configuration” menu item.

The frontend is provided in a separate port, net-mgmt/zabbix-frontend.  As for what happened after trying to install the frontend (DB, apache config, etc.), you will need to seek support from the Zabbix community.  That is not a problem with FreeBSD or the port.  I am using these ports daily on 8.1 amd64 without any issues.

- Jim

More information about the freebsd-ports mailing list