Firefox 3.6 installation problem

Beat Gaetzi beat at
Sat Mar 13 13:53:54 UTC 2010


> Hello,all!
> I'm trying to install firefox 3.6 from /usr/ports/www/firefox.
> First, I pkg_delete'd previousely installed firefox 3.0,
> but when doing make install clean I see the following errors:
> ../../dist/system_wrappers/pango/pango.h:3:30: error: pango/pango.h:
> No such file or directory
> and
> ../../dist/system_wrappers/pango/pangocairo.h:3:35: error:
> pango/pangocairo.h: No such file or directory
> and other errors, which seem to be caused by  pango's headers search
> failure.
> But WHY headers are searched for in ../../dist/system_wrappers/...,
> although during installation they are palced in
> /usr/ports/www/firefox/work/mozilla-1.9.2/config/system_wrappers ???
> What concern is ../dist/.. of?
> I even tried to copy all pango's headers to /usr/local/include,
> but with the same result.
> And initially there were no pango's headers in /usr/local/include

They should be installed in /usr/local/include/pango-1.0/pango/

> How can work around this?

Which version of Pango do you have installed? It should be Pango 1.14 or
higher. If not could you please update your Pango installation.


More information about the freebsd-ports mailing list