Firefox 3.6 installation problem

Dmitry Lunts eingorn777 at
Sat Mar 13 12:01:03 UTC 2010

I'm trying to install firefox 3.6 from /usr/ports/www/firefox.
First, I pkg_delete'd previousely installed firefox 3.0,
but when doing make install clean I see the following errors:
../../dist/system_wrappers/pango/pango.h:3:30: error: pango/pango.h:
No such file or directory


../../dist/system_wrappers/pango/pangocairo.h:3:35: error:
pango/pangocairo.h: No such file or directory

and other errors, which seem to be caused by  pango's headers search failure.

But WHY headers are searched for in ../../dist/system_wrappers/...,
although during installation they are palced in
/usr/ports/www/firefox/work/mozilla-1.9.2/config/system_wrappers ???

What concern is ../dist/.. of?

I even tried to copy all pango's headers to /usr/local/include,
but with the same result.

And initially there were no pango's headers in /usr/local/include

How can work around this?
TIA, Dmitry

$uname -a
FreeBSD domain 7.2-RELEASE-p7 FreeBSD 7.2-RELEASE-p7 #0: Fri Feb 26
19:51:57 UTC 2010
root at  i386

This release was installed thru "freebsd-update -r 7.2-RELEASE upgrade" from
FreeBSD 7.1

Best regards, Dmitry
email: eingorn777 at

More information about the freebsd-ports mailing list