spamassassin problem with upgrade

eculp eculp at
Fri Feb 12 13:48:27 UTC 2010

Quoting Guido Falsi <mad at>:

> On Fri, Feb 12, 2010 at 11:59:24AM +0100, Guido Falsi wrote:
>> On Fri, Feb 12, 2010 at 04:39:11AM -0600, eculp wrote:
>> > Spamassassin seems to crash everytime I try to start it.
>> >
>> > Starting spamd.
>> > child process [89827] exited or timed out without signaling
>> > production of a PID file: exit 25 at /usr/local/bin/spamd line 2544.
>> >
>> > It has always just worked.  Any suggestions.
>> Had this problem on two machines.
>> I solved it by deinstalling spamassassin and all perl modules it
>> depended upon, reinstalling it and all mandatory and optional perl
>> modules it requires.
> I'd also like to point out I user pkg_rmleaves to perform this task.
> This is easier than doing it by hand using pkg_delete and less error
> prone. You could, obviously, also have portmaster adn portupgrade
> perform the task, but they'd update a whole lot more ports which don't
> really need to be rebuilt.(like the perl interpreter itself)

Thanks for the recomendation.  I was concerned about the new perl  
default 5.10.  I have yet to update it.  Maybe I should just bit the  
bullet and do it all at once.  I'll look at pkg_rmleaves first.

Thanks for letting me know your solution for the error message.

Have a great day and weekend.

> --
> Guido Falsi <mad at>

More information about the freebsd-ports mailing list