www/firefox: Firefox 3.6 crashes, Firefox 3.5.7 not

O. Hartmann ohartman at zedat.fu-berlin.de
Mon Feb 8 19:02:55 UTC 2010

On 02/08/10 16:20, Gary Jennejohn wrote:
> On Mon, 08 Feb 2010 13:32:25 +0000
> "O. Hartmann"<ohartman at zedat.fu-berlin.de>  wrote:
>> Today, I upgraded Firefox 3.5.7 (built yesterday) to Firefox 3.6. After
>> deleting ~/.mozilla (after I did a buckup, of course), I tried a fresh
>> start of 'firefox3'. After firefox showed up, I realized that no
>> option-field (File, Extras etc) can be used, they are dead and after a
>> few seconds I clicked them, firefox3 is crashing.
>> Since I recompiled firefox 3.5.7 yesterday I was wondering if this is
>> due to some 'false' lib or dependency. Since I figured that I have
>> similar trouble with Thunderbird 3.0.1 after I installed it, I suspect a
>> faulty library causing this behaviour. With Thunderbird 3, I never
>> solved the problem although I tried to rebuild everything with
>> thunderbird via 'portmaster -f'. I'll did this with firefox 3.6 also,
>> but with no success.
>> The crashing is observed on two nearly identical SMP FreeBSD 8.0/amd64
>> STABLE boxes (make world of today), up-to-date ports. The crash is NOT
>> observed on my private oldish UP box, nearly the same setup, OS at the
>> same revision and ports up to date as of yesterday. Maybe this could be
>> a hint.
>> Any hints or suggestions?
> Try doing "ldd /usr/local/lib/firefox3/firefox-bin" and see if anything
> looks weird.
I did - and there is nothing weird.

I checked the installed libraries and they are all rebuild when 
rebuilding necessary dependencies for firefox3.

> You can porbably ignore
> /usr/local/lib/firefox3/firefox-bin:
>          libxul.so =>  not found (0x0)
>          libmozjs.so =>  not found (0x0)
>          libxpcom.so =>  not found (0x0)
> because run-mozilla.sh sets LD_LIBRARY_PATH to include
> /usr/local/lib/firefox3 where these libraries are installed.
> I merely deleted my old firefox 3.6 and reinstalled from the port (on
> 9-CURRENT AMD64) and haven't seen any problems.  But of course, I've
> been running various incarnations of 3.6 for a while and may have gotten
> all the dependencies already correctly installed.
> ---
> Gary Jennejohn
> _______________________________________________
> freebsd-stable at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-stable
> To unsubscribe, send any mail to "freebsd-stable-unsubscribe at freebsd.org"

I tried again, left the 'make config'-options as they were set by 
default, delete/backuped .mozilla in my home and they restartet 
firefox3. Nothing better than previously seen. Try hitting Button 
'Tools' at the top menu bar gives a menu after several seconds, then 
firefox crashes/core dumps.


More information about the freebsd-ports mailing list