[kde-freebsd] Call for Testing KDE 4.2 for FreeBSD

David Naylor naylor.b.david at gmail.com
Mon Feb 2 22:31:19 PST 2009


On Monday 02 February 2009 12:01:10 David Naylor wrote:
> On Sunday 01 February 2009 23:02:28 Martin Wilke wrote:
> > Howdy Guys,
> >
> > The KDE FreeBSD team is happy to announce the first public
> > Call for Testing for KDE 4.2. Over the past weeks we have
> > focused on the complex and very time consuming task to get
> > KDE 4.2 running.
> >
> > Please read UPDATING-area51 before you start your update.
> >
> > To get KDE 4.2:
> >    try
> >       svn co https://kf.athame.co.uk/kde-freebsd/trunk/area51/
> > /path/to/area51
> >
> >     More info here:
> >       https://kf.athame.co.uk/access.php
> >
> > - Martin (on behalf of the KDE FreeBSD team)
>
> Hi,
>
> I'll get started on testing today.  I however have this strange desire to
> use USB2 (the new USB stack introduced to FreeBSD-Current).

Just finished compiling on FreeBSD 7.1 and have found the following problems:
 1. The fonts are not being anti-aliased?  (Using default fonts and "Use 
anti-aliasing: Enabled {with sub-pixel rendering [RGB]}).
 2. Network Settings doesn't detect anything to do with FreeBSD (it probably 
still needs to be told about FreeBSD).  
 3. ksudo does not install?
 4. Samba config module doesn't find smb.conf by default.  It should look in 
multiple places?
 5. When I was changing desktop effects X froze. It was a once off thing...

Items 1,2, 4, (5) probably qualify for a PR, can anyone confirm these?

Item 3 probably has something to do with our ports.  I really prefer to use 
(k)sudo (since ksu doesn't like root without a password).  Item 4 should be 
fixed with a patch (until upstream comes with a proper solution).  

If you wait a few hours I'll see what I can do about providing patches for 
items 3, 4.

> Is KDE4 happy with USB2 (or to be more precise, is hald happy with USB2
> yet)?

I'll try compile hald with USB2.  If that doesn't work (i.e. starts taking 
100% CPU on a core) then I will not persue the issue.  I'm not sure ports has 
been converted to handle the base system's libusb20 in -current?

Oh and I am still having problems with HTTPS and proxy.  I am going to try put 
up a Squid proxy and see if Squid behaves better then WinGate.  And I am 
hoping Qt 4.5 will fix this proxy/socks problem (if it will hurry up and get 
released :-)). 

Everything else is looking good :-) and working on the FreeBSD side.  

Thanks

David

P.S. Any hope in getting Amarok 2 into ports with KDE 4.2.  Last I saw it was 
pending on a PR to fix mysql_embedded?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: This is a digitally signed message part.
Url : http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20090203/908a7020/attachment.pgp


More information about the freebsd-ports mailing list