portmaster-with-package-support release candidate available for testing

Alberto Villa villa.alberto at gmail.com
Sat Dec 12 01:10:03 UTC 2009

On Friday 11 December 2009 20:22:26 Doug Barton wrote:
> First, I'm assuming that you are using version 2.14 from ports. That's
> the latest version at the  moment.

i was using the latest revision, which seems to be the same as 2.14. 
upgraded to 2.14, now

> Next, I tried the exact same command line you used in your example and
> it worked for me.

it works for me too, now... great!

> If that doesn't expose the problem we're going to have to do more
> digging. First, are your world and kernel up to date and in synch?

just for reference, i'm working in a jail with 9-current installed last night 
(my live system is 8-rc2). i use jexec to access the jail, since i'm 
rebuilding all my ports to move my system to current

> Do you have anything in ~/.portmasterrc
> and/or /usr/local/etc/portmaster.rc currently? Next, do this:
> echo 'PM_VERBOSE=vopt' > ~/.portmasterrc

the only thing i have (referred to the next problem) is 
current in the environment

> Then run the commands that are giving you problems again. I did see
> your other messages about -P and --packages-build aborting if they
> can't find a package, that shouldn't be happening either, and does not
> happen in my testing; so something is definitely not working the way
> it should for you and I want to make sure that we figure out what it is.

could it be because my PACKAGESITE is actually an empty directory?
log here: http://pastebin.ca/1711679
Alberto Villa <villa.alberto at gmail.com>

Treaties are like roses and young girls -- they last while they last. -- 
Charles DeGaulle

More information about the freebsd-ports mailing list