Kde4 install - no Xorg

Da Rock rock_on_the_web at comcen.com.au
Fri Nov 28 16:29:35 PST 2008

Funny thing happened to me on a new install...

I installed 7.0 on a notebook because I wanted to (FINALLY!) see kde4
and I found out it was in ports. Plus I'm looking at just leaving
FreeBSD on this system seeing as I can't get my TV card to work even on
linux anymore.

So I installed, ran portsnap fetch extract, cd /usr/ports/x11/kde4, and
make install clean.

A day and a half later, the install is finished so I run kdm. Not found
so I run a find search and then run /usr/local/kde4/bin/kdm. It comes up
saying it can't find and run the Xserver on display :0. What the?!

So I run a search on pkg_version -v and find xorg is not installed- what
the?! Maybe I'm missing something here, but I thought installing kde4
would install xorg (I'm pretty sure it has before if I remember right-
it has been a while, but I'm sure I'm not that daft) as it kinda needs
it to run and ports generally install dependencies. Has someone
forgotten this in the Makefile?

Not trying to be picky, but I thought it might more sense and offer my
view :)

More information about the freebsd-ports mailing list