gnash-0.8.3: build fails on 6.3

Andriy Gapon avg at
Thu Jul 3 17:46:59 UTC 2008

on 01/07/2008 22:36 Dmitry Marakasov said the following:
> * Andriy Gapon (avg at wrote:
> Any news on the problem? I've gon 2 more reports of gnash failure on
> 6.3. I've tried to reproduce bug in 6.3 jail, but with no luck (tried
> rebuilding everything with different suspicios options that may affect
> gnash or ports it depends on (WITH_OPTIMIZED_CFLAGS, WITHOUT_DEBUG),
> also tried to build everything when multiple versions of gcc are present
> - it just builds without problems.

I also tried clean re-install (as opposed to upgrade via portupgrade)
and that resulted in the same error.

> Could you please mail me your make.conf and `pkg_info` output?

Let me send those a bit later.

Now an important finding - it seems that g++42 tries to use different
libstdc++, not its own.
I verified with nm that missing symbols are present in
/usr/local/lib/gcc-4.2.4/, but g++42 doesn't see them.
I explicitly added the library to command line and then linking succeeded.
I am quite puzzled as to why g++42 would not see its own libstdc++ or
prefer other libstdc++ over its own.
Might this be because of -L/usr/lib in the command line?

BTW, I have the following GCCs installed:
Plus base GCC 3.4.6.

And their libs:

Andriy Gapon

More information about the freebsd-ports mailing list