git on gjournal problem

Andriy Gapon avg at
Thu Jan 24 07:01:23 PST 2008

Antonios Anastasiadis wrote:
> I was cloning the linux kernel git tree on a gjournal'd partition.
> After git did its usual initial stuff it spat some errors during check
> out:
> ...
> Checking 23062 files out...
> error: git-checkout-index: unable to create file
> include/asm-arm/arch-integrator/cm.h (Interrupted system call)
> 100% (23062/23062) done
> Next thing, I run it again on a ufs2+su partition and everything goes
> fine, no errors, all files are checked out ok.
> I run it again on gjournal, same errors as before (but on different
> files, sometimes on a dozen, sometimes on a single file. Seems to kick
> in randomly).
> Tried it on another computer on a gjournal partition, the same errors
> occur.
> Looks like something is going on with git when gjournal is used.
> I don't have the know-how to look any further on the issue by myself, if
> someone is interested let me know how to help.


I am curios whether you get this problem with gjournal in 7.X or with
gjournal 6.X (added via gjournal6.patch) ?

Andriy Gapon

More information about the freebsd-ports mailing list