Xorg initial resolution broken

Randy Pratt rpratt1950 at embarqmail.com
Sun Oct 14 04:59:34 PDT 2007

On Sun, 14 Oct 2007 08:10:25 +0100
Mark Knight <markk at knigma.org> wrote:

> In message <4710FF43.8020408 at gmx.de>, "[LoN]Kamikaze"
> <LoN_Kamikaze at gmx.de> writes
> >Mark Knight wrote:
> >> Just restarted X after various Xorg updates.  Now the server seems to be
> >> completely ignoring the "Modes" line in the config file's Screen/Display
> >> section and picking its own initial resolution.
> >>
> >> No problem switching to the desired resolution later on when logged in.
> >>
> >> Config and log files here:
> >>
> >>   http://www.knigma.org.uk/scratch/resolution.txt
> >>
> >> This configuration has worked for years so I'm sure it's down to the
> >> Xorg update.  Any ideas please?
> >>
> >> Cheers,
> >
> >Set PreferredMode and check for the Virtual screen size in the log, you might
> >have to increase that to.
> Thanks for the tips.
> Setting PreferredMode caused the X server to lockup during start-up
> before switching out of text mode and requiring kill -9, until I removed
> my HorizSync and VertRefresh lines.
> Tried with X -configure afresh and achieved the same effect.
> With DDC and without HorizSync and VertRefresh lines PreferredMode is
> working but I'm having to use a lower refresh and I've lost the highest
> resolution my monitor displays.
> So for me the choice seems to be:
>   - stick with my old config and sort out resolution when I log in
>   - accept lower refresh (75Hz) and lower max resolution (rarely used it
>     anyway), and use PreferredMode

I'm having the same default resolution (1280x1024) problem using the
updated xf86-video-mga-1.9.100 driver and additionally am unable to
switch modes using the ctrl-alt-keypad +/- keys (Option "Dont Zoom"
_is_ disabled).

I reverted to the xf86-video-mga-1.4.7 driver and the desktop is
my normal 1024x768 resolution and the mode switch keys work.  Alas,
as my eyes age, the higher resolutions are unreadable.

Are you perhaps using the xf86-video-mga driver?  If so, reverting
to the older version may be another temporary workaround.


More information about the freebsd-ports mailing list