Cannot package converters/libiconv inside clean chroot

Tim Kientzle kientzle at
Sun Apr 8 04:46:03 UTC 2007

Ulrich Spoerlein wrote:
> I'm facing a strange problem, where I cannot pkg_add a libiconv.tbz
> which was build inside a clean chroot. I did the following (on
> RELENG_6).

I just tried following the steps you listed and
I don't see the same error:

# pkg_add -v libiconv-1.9.2_2.tbz
Requested space: 5744640 bytes, free space: 7040139264 bytes in 
extract: Package name is libiconv-1.9.2_2
extract: CWD to /usr/local
extract: /usr/local/man/man1/iconv.1.gz
extract: /usr/local/man/man3/iconv.3.gz
...... additional lines deleted ....
extract: execute '/sbin/ldconfig -m /usr/local/lib'
extract: CWD to .
Running mtree for libiconv-1.9.2_2..
mtree -U -f +MTREE_DIRS -d -e -p /usr/local >/dev/null
Attempting to record package into /var/db/pkg/libiconv-1.9.2_2..
Package libiconv-1.9.2_2 registered in /var/db/pkg/libiconv-1.9.2_2

Please send me the .tbz created on your system,
so I can try to figure out why pkg_add is failing.


Tim Kientzle

More information about the freebsd-ports mailing list