PHP 5.1.6 Command Line Arg Gives Seg Fault

Ron Tarrant rtarrant at sympatico.ca
Sun Sep 10 11:54:17 PDT 2006


Hi all,

I updated my ports tree on Sept. 7 and then built /usr/ports/lang/php5 
(version: 5.1.6). Now the command:

php --version

results in a segmentation fault. I wouldn't mind, but I'm working on 
building php-gtk2 from source and the configure script uses the above 
command to confirm installation of the CLI version of PHP. Rather than 
the test yielding:

"cli"

it yields:

"cli
Segmentation fault: 11 (core dumped)"

(including the linefeed) and , of course, the comparison fails.

Does anyone know if this had been fixed since the 7th?

If not, can anyone suggest a work-around without tampering too much with 
the php-gtk2 configure script?

-Ron T.

-- 
Ron Tarrant
Blog:<A HREF="http://www.writingup.com/blog/phpgtk2">PHP-Gtk2</A>



More information about the freebsd-ports mailing list