mailman upgrade broke "group mismatch"

Lee Dilkie Lee at
Wed Jun 7 02:11:42 UTC 2006


Something messed up with my portupgrade of mailman a couple of days ago. 
Mailman stopped working and posts to any of my lists result in:

   ----- The following addresses had permanent fatal errors -----
"|/usr/local/mailman/mail/mailman post mailman"
    (reason: 2)
    (expanded from: <...>)

   ----- Transcript of session follows -----
Group mismatch error.  Mailman expected the mail
wrapper script to be executed as group "mailman", but
the system's mail server executed the mail script as
group "mailnull".  Try tweaking the mail server to run the
script as group "mailman", or re-run configure, 
providing the command line option `--with-mail-gid=mailnull'.
554 5.3.0 unknown mailer error 2

I've tried changing the group on the /usr/local/mailman tree to "mailnull"

I've tried setting MM_GROUPNAME=mailnull and MM_GROUPID=26 (mailnull's group ID) in /etc/make.conf and running portupgrade -f mailman. In order for "configure" to work I have to "chgrp -R mailnull /usr/local/mailman" first. But that doesn't work in the end either. Actually, the web interface works but posts to lists don't do anything, no bounce either.

I've tried mv-ing /usr/local/mailman to another directory and re-installing mailman into a clean directory, copying over those files I think are important from the old dir (all my lists and stuff), and still it doesn't work. BTW, the default mailman from ports does *not* use group "mailnull", it uses "mailman".

Just what do I have to do to get my lists back up and working again?

please help,


More information about the freebsd-ports mailing list