portupgrade portupgrade leaves an error....

Sergey Matveychuk sem at FreeBSD.org
Sun Jul 2 07:33:34 UTC 2006

David J Brooks wrote:
> On Saturday 01 July 2006 09:48, Sergey Matveychuk wrote:
>> David J Brooks wrote:
>>> On Saturday 01 July 2006 08:57, Sergey Matveychuk wrote:
>>>> Sergey Matveychuk wrote:
>>>>> Kostik Belousov wrote:
>>>>>> On Sat, Jul 01, 2006 at 03:49:45PM +0400, Sergey Matveychuk wrote:
>>>>>>> David J Brooks wrote:
>>>>>>>> After running 'portupgrade portupgrade' I am left with the following
>>>>>>>> error when I run portversion or portupgrade, or pretty much any
>>>>>>>> program that addresses the ports collection:
>>>>>>>> /libexec/ld-elf.so.1:
>>>>>>>> /usr/local/lib/ruby/site_ruby/1.8/i386-freebsd6/bdb.so: Undefined
>>>>>>>> symbol "db_version"
>>>>>>>> Any ideas on how to fix it?
>>>>>>> I guess the problem can be if you use databases/db41. Can you send me
>>>>>>> list of packages you have installed (ls -1 /var/db/pkg)?
>>>>>> What I noted when last update to databases/ruby-bdb was made, is that,
>>>>>> despite settings of WITH_BDB=43, final shared object is linked with
>>>>>> db-4.4 library. As far as I remember, I got some similar error
>>>>>> when trying to use portinstall after that.
>>>>> Have you a few Berkley DB ports installed?
>>>> Yes, problem is with ruby-bdb port. If you have installed a few Berkley
>>>> db ports (e.g. db40, db42, db44) ruby-bdb configure script find the
>>>> highest version and will compiled with it, but if WITH_BDB points on
>>>> other version, the port will formed wrong and will not work.
>>> These are the db versions that I have installed:
>>> db4-4.0.14_1,1
>>> db41-4.1.25_3
>>> db42-4.2.52_4
>>> This is what is set in /var/db/ports/portupgrade/options:
>>> WITH_BDB4=true
>>> I'm not sure which of those installed versions is being built against
>>> and/or linked to...
>> It's linked with db42 but should with db4.
> OK. I changed the options file to WITH_BDB42=true
> and now portupgrade has this message as it begins to compile:
> "Neither WITH_DBD4 nor WITH_BDB1 are defined. Will use DBD driver."
> And when run produces the same error.
> /libexec/ld-elf.so.1: /usr/local/lib/ruby/site_ruby/1.8/i386-freebsd6/bdb.so: 
> Undefined symbol "db_version"
> Setting the options file to WITH_BDB=42 has the same result.
> I guess I'm not setting that option properly.. what should it look like?
> David

Did you rebuild both ruby-bdb and portupgrade (with 'make config' before)?


More information about the freebsd-ports mailing list