X server will not run as user

Roman Neuhauser neuhauser at sigpipe.cz
Sun Sep 25 23:47:30 PDT 2005

# inmylifetime17 at optonline.net / 2005-09-25 23:51:27 -0400:
> Hello everyone, earlier on today my /var/ slice for my
> FreeBSD-5.4-release was full, so i erased some log files and the files
> inside of my /tmp/ dir also, which freed up about 60% of space. I
> restarted my laptop later on that night and when i tried to run startx
> to bring up my xserver for xfce i got this error message

> The overwriting error message was : Failed to create file '/var/tmp/.xfsm-ICE-V3CIRR : Permission 
> denied.  

> Oddly enough when i run startx as root it works, which is how im
> sending this email now. Does this make any sense to anyone?

    Wrong permissions on /var/tmp, should be 01777 (drwxrwxrwt).

How many Vietnam vets does it take to screw in a light bulb?
You don't know, man.  You don't KNOW.
Cause you weren't THERE.             http://bash.org/?255991

More information about the freebsd-ports mailing list