X server will not run as user

inmylifetime17 at optonline.net inmylifetime17 at optonline.net
Sun Sep 25 20:51:28 PDT 2005

Hello everyone, earlier on today my /var/ slice for my FreeBSD-5.4-release was full, so i erased 
some log files and the files inside of my /tmp/ dir also, which freed up about 60% of space. I 
restarted my laptop later on that night and when i tried to run startx to bring up my xserver for 
xfce i got this error message "(xfce4-session:065):Glib-warning **:GEerror set over the top a 
previous GEerror or unintialized memory. You must ensure an error is NULL before it's set.

The overwriting error message was : Failed to create file '/var/tmp/.xfsm-ICE-V3CIRR : Permission 

Segmentation Fault

Agent pid 602 killed"

Oddly enough when i run startx as root it works, which is how im sending this email now. Does this 
make any sense to anyone? I have tried search google but all that comes up is other Glib errors 
but they have to do with realplayer. Can anyone help me out please?

More information about the freebsd-ports mailing list