Ruby portupgrade but not a segfault, asks for non existant db40

alex theawel at
Wed Mar 23 01:07:23 PST 2005

You know what I did, now I do remember adding that when I installed 
MySQL. I guess my next question would be how can I get portupgrade to 
work with that in my make.conf? Would installing DB4 correct the 
problem, and if so why does ruby ask for the specific directory db40 
and not db4?

On Mar 23, 2005, at 3:47 AM, Michael Nottebrock wrote:

> On Wednesday, 23. March 2005 07:07, Alex wrote:
>> I have attempted to update my INDEX.db file using the usual command:
>> /usr/local/sbin/portsdb -Uu
>> This has worked for me all the time until tonite, when I tried the
>> command tonite i got an error that said ruby required db40, but when i
>> looked a bit further i noticed that there is no such directory like
>> that. There is db4 and db41. Why all of a sudden is it asking me for
>> this dependency when it clearly does not exist and never did. I
>> searched the listing in google to verify.
> Do you have WITH_BDB_VER=40 set in make.conf perhaps?
> -- 
>    ,_,   | Michael Nottebrock               | lofi at
>  (/^ ^\) | FreeBSD - The Power to Serve     |
>    \u/   | K Desktop Environment on FreeBSD | http://freebsd.kde.o

More information about the freebsd-ports mailing list