Ruby portupgrade but not a segfault, asks for non existant db40

Michael Nottebrock michaelnottebrock at
Wed Mar 23 00:47:28 PST 2005

On Wednesday, 23. March 2005 07:07, Alex wrote:
> I have attempted to update my INDEX.db file using the usual command:
> /usr/local/sbin/portsdb -Uu
> This has worked for me all the time until tonite, when I tried the
> command tonite i got an error that said ruby required db40, but when i
> looked a bit further i noticed that there is no such directory like
> that. There is db4 and db41. Why all of a sudden is it asking me for
> this dependency when it clearly does not exist and never did. I
> searched the listing in google to verify.

Do you have WITH_BDB_VER=40 set in make.conf perhaps?

   ,_,   | Michael Nottebrock               | lofi at
 (/^ ^\) | FreeBSD - The Power to Serve     |
   \u/   | K Desktop Environment on FreeBSD |
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-ports mailing list