FreeBSD Port: qemu-0.7.0s200528

Juergen Lock nox at
Thu Jun 2 18:36:23 GMT 2005

On Wed, Jun 01, 2005 at 09:09:13AM +0000, Osmany Guirola Cruz wrote:
> Hi
>  I installed qemu recently and saw some errors during the installation and running the program
> .
> i installed the port with 
> %make WITH_KQEMU=yes install clean
> but the kqemu.ko was not installed then i do make WITH_KQEMU=yes install without cleaning and copy 
> the kqemu.ko file to my home :-( and load it as root..

Thats weird, it installs into /boot/kernel here no problem.

> the first time i run qemu the module was not loaded and see a warning "/dev/kqemu does not exist" i do
> and installation of winXP and was very very very SLOW. and running the OS was SLOW too.
> the i storp qemu load the module and run qemu again but after a few seconds during the boot proccess qemu freeze
> i do a top to see the status of the proccess and get this
>  45558 osmany      76    0   281M 75008K WAIT     0:24  0.00%  0.00% qemu
> i try to kill -9  45558
> close the qemu window with the mouse with ctrl-c a try everithing 
> the only way is reseting the machine :-( because the process never die 
> of course i can't unload the module because qemu was using it.
> the problem is that without kqemu qemu it's very slow and with kqemu does not work
> What can i do, this is normal or i have to do EXTRA tunning on my system to use qemu without problems

 No there is no extra tuning required.  Maybe it doesnt like
that particular version of XP, dunno...  OTOH this is the first time
I've read of a problem like this, you could post on qemu-devel if
anyone else has seen something like it.  (I myself have only tried
free OSes on (k)qemu and had no such troubles yes.)

 Sorry that I don't have an immediate solution,

More information about the freebsd-ports mailing list