mpeg4ip requires IPv6?

Scott I. Remick scott at
Thu Jan 6 06:40:58 PST 2005

I should prefix this by saying that I have mpeg4ip working now, but I'd
still like to address the concerns you raised.

On Wed, 5 Jan 2005 16:10:38 -0800, Michael C. Shultz wrote:

> I don't have on my FreeBSD-5 Stable system, are you running 
> FreeBSD 4 or 5?


> locate on my FreeBSD 5.3 returns:
> /lib/
> /usr/compat/linux/lib/
> /usr/lib/

On mine I get: 


> If you are running FreeBSD 5 you probably have dependencies linked
> to out of date libraries and the dependencies should be upgraded, if
> your running FreeBSD 4 then never mind.

How can I find everything that's linked to these out-of-date libraries so I
know which to rebuild?

> look in your /usr/local/include/mp4.h file if you have one and see
> if "MP4IsIsmaCrypMediaTrac" is in there,

It is:

bool MP4IsIsmaCrypMediaTrack(
        MP4FileHandle hFile,
        MP4TrackId trackId);

But I don't think we're concerned about that anymore, since mpeg4ip is now
working, right? I am not sure what did it, but I tried ripping out
everything AGAIN and reinstalling and this time it worked. 

I'd appreciate advice on how to fix these old library dependencies, though,
since I don't want anything else screwing up in the future (actually I have
problems w/ SimGear and openoffice still). Thanks!

More information about the freebsd-ports mailing list