xfce4 port expat/p5-XML-Parser problem

John Murphy sub00 at freeode.co.uk
Wed May 26 14:03:00 PDT 2004

Michael Nottebrock <michaelnottebrock at gmx.net> wrote:

>On Wednesday 26 May 2004 19:02, John Murphy wrote:
>> /usr/ports/UPDATING seemed to suggest portupgrade -rf textproc/expat2
>> so I did that and got a libexpat.so.5 in /usr/local/lib which didn't help
>> ln -s libexpat.so.5 libexpat.so.4 in /usr/local/lib got it going again
>Don't do this. You rather need to get all references to libexpat.so.4 out of 
>your system. Remove the symlink, rebuild/reinstall fontconfig and build 
>p5-XML-Parser from source. In general, you really can't use the 5.2.1-R 
>packages from the FTP servers anymore once you've installed up-to-date ports, 
>the packages are simply too old and will have all sorts of stale references.

Thanks again Michael.  It worked and the install completed.  Seems there are
still references to libexpat.so.4 though as I cant run an xfterm and when I
close the session there is a libexec/ld-elf.so.1:Shared object "libexpat.so.4"
not found error for every time I tried to.

Would a make deinstall and make reinstall in /usr/ports/x11-wm/xfce4 fix it?

Thanks for the tip about packages.
I was going to pkg_add mozilla next but I'll build it from source instead.


More information about the freebsd-ports mailing list