xfce4 port expat/p5-XML-Parser problem

Michael Nottebrock michaelnottebrock at gmx.net
Wed May 26 15:23:00 PDT 2004

On Wednesday 26 May 2004 23:02, John Murphy wrote:

> Thanks again Michael.  It worked and the install completed.  Seems there
> are still references to libexpat.so.4 though as I cant run an xfterm and
> when I close the session there is a libexec/ld-elf.so.1:Shared object
> "libexpat.so.4" not found error for every time I tried to.
> Would a make deinstall and make reinstall in /usr/ports/x11-wm/xfce4 fix
> it?

You can find out which port/package installed which file by doing pkg_info 
-W /path/to/file. xfterm is installed by x11-wm/xfce - since you seem to 
actually want xfce4 you should perhaps just deinstall xfce completely and use 
xfterm4, which is xfce4's terminal application?

However, if you actually meant xfterm4, that belongs to sysutils/xfce4-utils, 
so you should try reinstalling that (x11-wm/xfce4 is a so-called metaport 
which exists mainly to facilitate installing a collection of other ports - 
deinstalling and reinstalling it will not change/update any of the ports 
which actually provide the programs/data).

However, sometimes you may find that even after recompiling, a binary still 
references a shared library which doesn't exist anymore. This can happen if a 
different shared library this binary links to is itself linked to the 
nonexistent lib. You can find out to what libraries a binary is linked by 
doing ldd /path/to/binary. You can then again find out with ldd which of 
those libraries link to what other libraries, eventually finding the one 
which references the obsolete library, which you can then find the respective 
port for with pkg_info -W and recompile (of course you can also ldd and grep 
your way through /usr/local/lib and /usr/X11R6/lib).

   ,_,   | Michael Nottebrock               | lofi at freebsd.org
 (/^ ^\) | FreeBSD - The Power to Serve     | http://www.freebsd.org
   \u/   | K Desktop Environment on FreeBSD | http://freebsd.kde.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: signature
Url : http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20040527/459d740e/attachment.bin

More information about the freebsd-ports mailing list