thread library stuff with gaim .77 (yes, I read UPDATING)

Kris Kennaway kris at
Mon May 24 22:46:10 PDT 2004

On Mon, May 24, 2004 at 10:10:16PM -0700, Mike Hunter wrote:
> Hi,
> I recently upgraded gaim (always a mistake it seems :( ) and I can't get
> it to start up anymore.
> % gaim
> Fatal error 'Spinlock called when not threaded.' at line 83 in file
> /usr/src/lib/libpthread/thread/thr_spinlock.c (errno = 0)
> Abort trap (core dumped)
> I've read /usr/src/UPDATING, and I tried the suggestion about switching
> the thread libraries.  When I tried that, gaim worked but Firefox stopped
> functioning :(  When I tried to rebuild firefox, it gave me a **build
> error** complaining about an assertion failure and threading.
> When I try to only have the UPDATING change apply for gaim as follows:
> [/usr/X11R6/bin/gaim]
> It still gives the same error message as above.
> So my main point of confusion is that I can't seem to make the thread
> change apply only to gaim :(  Some library gaim uses perhaps?

Yes, probably some other swhared library.

> Also, rebuilding gaim didn't help...even portupgrade -r -f gaim.

Use the libchk port to look for things linked to libc_r, and rebuild them.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-ports mailing list