thread library stuff with gaim .77 (yes, I read UPDATING)

Mike Hunter mhunter at ack.Berkeley.EDU
Mon May 24 22:11:18 PDT 2004


I recently upgraded gaim (always a mistake it seems :( ) and I can't get
it to start up anymore.

% gaim
Fatal error 'Spinlock called when not threaded.' at line 83 in file
/usr/src/lib/libpthread/thread/thr_spinlock.c (errno = 0)
Abort trap (core dumped)

I've read /usr/src/UPDATING, and I tried the suggestion about switching
the thread libraries.  When I tried that, gaim worked but Firefox stopped
functioning :(  When I tried to rebuild firefox, it gave me a **build
error** complaining about an assertion failure and threading.

When I try to only have the UPDATING change apply for gaim as follows:


It still gives the same error message as above.

So my main point of confusion is that I can't seem to make the thread
change apply only to gaim :(  Some library gaim uses perhaps?

Also, rebuilding gaim didn't help...even portupgrade -r -f gaim.



More information about the freebsd-ports mailing list