build failure in astro/celestia port

Kent Stewart kstewart at
Sun Jan 25 11:09:21 PST 2004

On Sunday 25 January 2004 08:19 am, David Fleck wrote:
> On Sat, 24 Jan 2004, Kent Stewart wrote:
> > On Saturday 24 January 2004 06:04 pm, David Fleck wrote:
> > > Trying to build the celestia port, getting a configure error.  I
> > > sent this information to the maintainer about 3 weeks ago,
> > > haven't heard back.
> > >
> > > cvsupping the port as of this morning resulted in same error.
> >
> > You upgraded gettext and did not force build the packages that used
> > it. Now you have a mix of packages that want version 10.x and 12.x.
> ???? I don't see the relationship with this error at all.  I was
> getting this error weeks ago, before updating gettext.

You had the following entry in your log

/usr/libexec/elf/ld: warning:, needed 
by /usr/X11R6/lib/, may conflict with
/usr/X11R6/lib/ undefined reference to 
`XmuLookupStandardColormap' was the library installed by the old version of gettext. 
You didn't have a clean setup to start the install until you upgraded 
to everything to using 0.12.1. 

> Just in case, I reinstalled 0.12.1 version of gettext, and recompiled
> everything on the system that depended on it.
> Same error:
> checking for GL/gl.h... yes
> checking for glNewList in -lGL... yes
> checking for GL/glu.h... yes
> checking for gluLookAt in -lGLU... yes
> checking for GL/glut.h... yes
> checking for glutKeyboardUpFunc in -lglut... no
> ===>  Script "configure" failed unexpectedly.
>       Please report the problem to trevor at [maintainer]
> and attach
>       the "/usr/ports/astro/celestia/work/celestia-1.2.4/config.log"
> including
>       the output of the failure of your make command. Also, it might
> be a good idea to provide an overview of all packages installed on
> your system (e.g. an `ls /var/db/pkg`). *** Error code 1
> This looks to me as though the current version of celestia depends on
> a version of libglut that is not in the ports tree.

It has libglut-5.0.2 as a reference and you have it intalled. Since it 
can't find the one feature, it sure looks like that might be the case. 

Ordinarily, I wouldn't try building it on my system because it has so 
many gnome references that may affect the setup of my KDE based test 
machine. I figured out an easy way of keeping track of what ports were 
added and tried building it. 

The config log shows

checking for gluLookAt in -lGLU... yes
checking for GL/glut.h... yes
checking for glutKeyboardUpFunc in -lglut... yes

As the following search shows, it installed just fine

ruby# pkgrep celest
celestia-1.2.4      Scriptable space flight simulator for X

It appears that you have something installed that is out of date.


Kent Stewart
Richland, WA

More information about the freebsd-ports mailing list