build failure in astro/celestia port

David Fleck david.fleck at
Sun Jan 25 08:19:55 PST 2004

On Sat, 24 Jan 2004, Kent Stewart wrote:

> On Saturday 24 January 2004 06:04 pm, David Fleck wrote:
> > Trying to build the celestia port, getting a configure error.  I sent
> > this information to the maintainer about 3 weeks ago, haven't heard
> > back.
> >
> > cvsupping the port as of this morning resulted in same error.
> You upgraded gettext and did not force build the packages that used it.
> Now you have a mix of packages that want version 10.x and 12.x.

???? I don't see the relationship with this error at all.  I was getting
this error weeks ago, before updating gettext.

Just in case, I reinstalled 0.12.1 version of gettext, and recompiled
everything on the system that depended on it.

Same error:
checking for GL/gl.h... yes
checking for glNewList in -lGL... yes
checking for GL/glu.h... yes
checking for gluLookAt in -lGLU... yes
checking for GL/glut.h... yes
checking for glutKeyboardUpFunc in -lglut... no
===>  Script "configure" failed unexpectedly.
      Please report the problem to trevor at [maintainer] and
      the "/usr/ports/astro/celestia/work/celestia-1.2.4/config.log"
      the output of the failure of your make command. Also, it might be a
good idea to provide an overview of all packages installed on your system
(e.g. an `ls /var/db/pkg`). *** Error code 1

This looks to me as though the current version of celestia depends on a
version of libglut that is not in the ports tree.

David Fleck
david.fleck at

More information about the freebsd-ports mailing list