FreeBSD Port: jakarta-tomcat5-5.0.16

Kang Liu liukang at bjpu.edu.cn
Fri Jan 16 07:25:00 PST 2004


> -----Original Message-----
> From: owner-freebsd-ports at freebsd.org
> [mailto:owner-freebsd-ports at freebsd.org] On Behalf Of Xin LI
> Sent: Friday, January 16, 2004 11:00 PM
> To: Kang Liu; dadelcas at cantv.net
> Cc: ports at FreeBSD.org
> Subject: Re: FreeBSD Port: jakarta-tomcat5-5.0.16
>
> I think a new feature could be added to the bsd.{foo}.mk,
> sometimes a port can run with a minimum version of a certain
> "environment"-ish port, e.g.,
> tomcat5 runs on JDK 1.3+, however, it may be best working
> with JDK 1.4.
> (Just take these as example, I don't mean tomcat5 will or
> will not work best with JDK 1.3 or 1.4, though.)
>
> With this in consideration, I'd proposal some knob like
> USE_JAVA_PREFER= 1.4 and this will cause the port to
> automatically install JDK 1.4 if there's no JDK installed.
> Also, this should apply to other ports like perl, php, etc.
>
> Just my own 0.02 Yuan :)
>
> Cheers,
> Xin LI

USE_JAVA_PREFER=1.4 :-)
I think it is a good idea.
If we set a variable like this
then we could not only set the version of jdk but also choose prefer native jdk (diablo) or not.

Regards,
Kang




More information about the freebsd-ports mailing list