Solved: Error building XFree86 from ports

Doug Cook dcook at
Thu Apr 15 23:48:37 PDT 2004

Seems to be a recurring issue (a couple of postings in the archives, but
nothing particularly definitive), so here is the problem and the

Building XFree86-4 in ports, I ran into two different build problems.
First, the build would fail with an error about file "GccWarningOptions"
not found.  GccWarningOptions was supposed to have been defined and
replaced with actual GCC options like "-Wall", but it was undefined and
therefore left on the GCC command line, so GCC tried to find the
GccWarningOptions file...

Patching the file to fix this, I ran into additional trouble
with FreeType -- GCC unable to find ft2build.h.  I had to add
/usr/local/include and /usr/local/include/freetype2 to the include path,
and /usr/local/lib to the lib path, then things kindof worked.  But at
this point, I'm guessing it is more than a glitch in the makefile.

To make the story a bit shorter, I had both imake and imake-4 installed,
and they seemed to conflict.  pkg_delete imake, then a "make deinstall
install" in imake-4, and finally a make clean in XFree86-4, and all is
well again.

Perhaps imake-4 should refuse to install if imake is already installed?


More information about the freebsd-ports mailing list