databases/mysql-server build problems with dns/bind installed as base?

Matthew Seaman matthew at
Tue Oct 14 06:34:32 PDT 2003

On Tue, Oct 14, 2003 at 02:15:38PM +0100, Matt Sealey wrote:
> I'm leaning towards blaming my installations of BIND (PORT_REPLACES_BASE_BIND8=yes)
> I'm sure I had this problem a year or two back when I ran 4.x on a server, but
> I can't remember how I solved it, if at all.
> Anyone got any ideas what's broken here, and if it can be fixed (either in the
> BIND port, or the MySQL port)?

Sounds like you've mixed up the C header files from the system (see
the definition of h_errno in /usr/include/netdb.h) and your new
resolver library code, where h_errno can be turned into a macro hiding
a function __h_errno() rather than a global variable -- see for
example /usr/src/contrib/bind/include/netdb.h or the equivalent from

Either link mysql entirely against the system version of the resolver
library, or entirely against the BINDv8 resolver from the port. You
can probably do that by intelligent application of -I and -L flags
during the MySQL compilation, which requires a little fiddling about
with CONFIGURE_ARGS and/or CONFIGURE_ENV ib the MySQL port directory.



Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP:         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-ports mailing list