databases/mysql-server build problems with dns/bind installed as base?

Matt Sealey matt at
Tue Oct 14 06:15:40 PDT 2003

Hello there,

I'm trying to upgrade my MySQL server, I'm running FreeBSD 5.1 which is
pretty plain and boring.. but it fails with a linker error every time:

root at risky:/home/neko$ portupgrade mysql-server-4.0.14
--->  Upgrading 'mysql-server-4.0.14' to 'mysql-server-4.0.15' (databases/mysql40-server)
--->  Building '/usr/ports/databases/mysql40-server'
===>  Cleaning for mysql-client-4.0.15
===>  Cleaning for p5-DBD-mysql-2.1026_1
===>  Cleaning for p5-DBI-1.38
===>  Cleaning for libtool-1.3.5_1
===>  Cleaning for perl-5.6.1_14
===>  Cleaning for mysql-server-4.0.15

.. blah blah

cc -O3 -DDBUG_OFF -O2 -mcpu=pentiumpro -mcpu=i686 -O3 -fno-omit-frame-pointer -o perror perror.o ../mysys/libmysys.a
../strings/libmystrings.a -lz -lcrypt -lm -lc_r
source='resolveip.c' object='resolveip.o' libtool=no  depfile='.deps/resolveip.Po' tmpdepfile='.deps/resolveip.TPo'  depmode=gcc3
sh ../depcomp
 cc -DHAVE_CONFIG_H -I. -I. -I.. -I./../include -I../include -I..     -O3 -DDBUG_OFF -O2 -mcpu=pentiumpro -mcpu=i686 -O3
-fno-omit-frame-pointer -c `test -f resolveip.c || echo './'`resolveip.c
/bin/sh ../libtool --mode=link cc  -O3 -DDBUG_OFF -O2 -mcpu=pentiumpro -mcpu=i686 -O3 -fno-omit-frame-pointer    -o resolveip
p.o ../mysys/libmysys.a  ../dbug/libdbug.a ../strings/libmystrings.a -lz -lcrypt -lm  -lc_r
cc -O3 -DDBUG_OFF -O2 -mcpu=pentiumpro -mcpu=i686 -O3 -fno-omit-frame-pointer -o resolveip resolveip.o ../mysys/libmysys.a
bug.a ../strings/libmystrings.a -lz -lcrypt -lm -lc_r
resolveip.o: In function `main':
resolveip.o(.text+0x2cf): undefined reference to `__h_errno'
*** Error code 1

Stop in /usr/ports/databases/mysql40-server/work/mysql-4.0.15/extra.
*** Error code 1

Stop in /usr/ports/databases/mysql40-server/work/mysql-4.0.15.
*** Error code 1

Stop in /usr/ports/databases/mysql40-server/work/mysql-4.0.15.
*** Error code 1

Stop in /usr/ports/databases/mysql40-server.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade9325.0 make
** Fix the problem and try again.
** The following packages were not installed or upgraded (*:skipped / !:failed)
        ! databases/mysql40-server (mysql-server-4.0.14)        (linker error)

It happens with the 4.1 port too, with or without optimisation flags, I have


.. in my /etc/make.conf but it makes no difference whether I have nothing
in there.

I'm leaning towards blaming my installations of BIND (PORT_REPLACES_BASE_BIND8=yes)

I'm sure I had this problem a year or two back when I ran 4.x on a server, but
I can't remember how I solved it, if at all.

Anyone got any ideas what's broken here, and if it can be fixed (either in the
BIND port, or the MySQL port)?

Thanks in advance

Matt Sealey <matt at>

More information about the freebsd-ports mailing list