diablo-jre and libintl.so.4 problem

Andrew J Caines A.J.Caines at halplant.com
Thu Oct 9 18:29:04 PDT 2003


> I'm using FreeBSD 5.1-p8 and I'm trying to install diablo-jre plugin in
> mozilla and firebird.

AOL, but STABLE in my case.

> LoadPlugin: failed to initialize shared library
> /usr/local/diablo-jre1.3.1/plugin/i386/ns600/libjavaplugin_oji.so 
> [Shared object "libintl.so.4" not found]
> If I reinstall everything the same error happens.

The diablo-jre1.3.1 port downloads a pre-built JRE distribution due to
licensing issues with this lib linked against libintl.so.4.

> Does anyone know how to correct this problem?

Temporarily you can fudge it by linking libintl.so.5 to libintl.so.4, but
in the longer term I hope we'll have a new native JRE for 4.9.

> I used to have the same problem with graphics/gview, but is was solved
> when I reinstall everything.

That was probably the simpler case of rebuilding from source and linking
to the current version of the lib.

| -Andrew J. Caines-   Unix Systems Engineer   A.J.Caines at halplant.com  |
| "They that can give up essential liberty to obtain a little temporary |
|  safety deserve neither liberty nor safety" - Benjamin Franklin, 1759 |

More information about the freebsd-ports mailing list