bikeshed for all!

Julian Elischer julian at
Thu Dec 13 15:01:35 PST 2007

> I'd suggest to go with any kind of spelling of 'fibid', 'fib_id',
> 'FIBid', or ...  as that's what it is called these days.
inside the kernel I'll be sticking with the rt_ prefix 
to reduce confusion. I think I'll go with the tableid name used in 
openBSD for compat reasons, and its succinct.

however in the user visible portion I'm still lookig for a name for the 
utility.. (similar to nice, jail, chroot)

looking for something that flows off the fingers nicely..

fib 1 ping  

might work for me
# fib 1 sysctl net.my_fib

since I've never heard of it before I don't know how standard FIB is?

setfib 1 (mumble)

I think the contenders are:

Base                        short version             utility name
instance  (ala Juniper)     inst? rtinst              rtinst
vrf (ala cisco)                                       vrf, setvrf
fib   ala someone else                                fib, setfib

and a late contender:

routes 1 ping   
(note plural)

More information about the freebsd-net mailing list