webcam and audio capture

Michael Zhilin mizhka at
Sat Dec 26 09:39:25 UTC 2015

Hi Marco,

Do you have tried to change default_unit to 4? I don't remember exact
sysctl node, but it's easy to grep it:

sysctl -a | grep default_unit

It worked for me before to resolve all troubles with sound.

On 25 Dec 2015 14:49, "Marco Beishuizen" <mbeis at> wrote:

> Hi,
> I have a Logitech C270 webcam and I was trying to get webrtc working
> (Firefox Hello). Sound (output) works just fine all the time.
> Video capture is being recognized and works, but not audio capture (the
> microphone in the webcam).
> The video capture device is /dev/video0 and when testing at
>, Firefox asks nicely if I would like to share the
> /dev/video0 device. But the audio device is skipped and doesn't work. In FF
> Hello, video is fine, but the microphone on my side isn't working. I can
> hear and see the people on the other side. But they can see me, but cannot
> hear me.
> I have encountered similar problems before with uTox. But in uTox it
> worked after editing a config file (in ~/.alsoftrc pointing the audio
> capture from /dev/dsp (default?) to /dev/dsp4).
> The big question is, if it is possible in FreeBSD to always point the
> audio capture to /dev/dsp4, instead of /dev/dsp which seems to be the
> default?
> Regards,
> Marco
> --
> Military intelligence is a contradiction in terms.
>                 -- Groucho Marx
> _______________________________________________
> freebsd-multimedia at mailing list
> To unsubscribe, send any mail to "
> freebsd-multimedia-unsubscribe at"

More information about the freebsd-multimedia mailing list