mplayer video output driver not working

Kevin Smith smithcam at
Fri Nov 26 00:14:09 PST 2004

I tried what you suggested (explicitely named the device and also 
commenting out the mpeg12 entry in the codecs.conf and get similar 
results (see output below - goes to next avail driver)...I didn't have 
anything in the .config file (it was empty).  I'm wondering if there is 
a debug mode I can run mplayer in.  I looked at the man page - lots of 
command line options in this program  !

 mplayer -vo xv dvd:// -dvd-device /dev/acd0
MPlayer 1.0pre5-3.4.2 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Foster 3001 MHz (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Reading config file /usr/local/share/mplayer/mplayer.conf: No such file 
or directory
Reading config file /home/kevin/.mplayer/config
Reading /home/kevin/.mplayer/codecs.conf: Can't open 
'/home/kevin/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/share/mplayer/codecs.conf: 73 audio & 179 video codecs
Font /home/kevin/.mplayer/font/font.desc loaded successfully! (206 chars)
Using usleep() timing
Can't open input config file /home/kevin/.mplayer/input.conf: No such 
file or directory
Input config file /usr/local/share/mplayer/input.conf parsed: 53 binds

Playing dvd://.
Reading disc structure, please wait...
There are 29 titles on this DVD.
There are 1 chapters in this DVD title.
There are 1 angles in this DVD title.
DVD successfully opened.
MPEG-PS file format detected.
MPEG: No audio stream found -> no sound.
VIDEO:  MPEG2  720x480  (aspect 2)  29.970 fps  8000.0 kbps (1000.0 kbyte/s)
vo: X11 running at 1600x1200 with depth 16 and 16 bpp (":0.0" => local 
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffmpeg2] vfm:ffmpeg (FFmpeg MPEG 2)
Audio: no sound
Starting playback...
VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 720x540 Planar YV12
V:   0.0    1   0%  0%  0.0% 0 0 0%

Exiting... (End of file)

Michael Nottebrock wrote:

>On Friday, 26. November 2004 07:13, Kevin Smith wrote:
>>PS, since xine is working, i ran xine --verbose and noticed that it was
>>using the xv output driver, so this is working with xine, but not with
>>mplayer -vo xv  [..]    (I tried -vo gl and a bunch of others to no avail.)
>The video driver is not likely to be the problem.
>Try specifying the device directly (for example mplayer dvd:// 
>-dvd-device /dev/acd0c). If you have both ata and atapicam enabled, try both 
>the acd device and the cd device (you may have to modify permissions first).
>Have you by chance specified a cache in .mplayer/config, or hardframedrop? The 
>libmpeg2 decoder doesn't like most of the options - try to 
>rename .mplayer/config to something else to make sure you run with defaults. 
>If that still doesn't help, try editing /usr/local/share/mplayer/codecs.conf 
>and comment out this paragraph completely (prefix each line with a ";"):
>videocodec mpeg12
>  info "MPEG 1 or 2 (libmpeg2)"
>  comment "with postprocessing"
>  status working
>  format 0x10000001  ; mpeg 1
>  format 0x10000002  ; mpeg 2
>  driver libmpeg2
>  dll "libmpeg2"
>  out YV12,I420,IYUV

More information about the freebsd-multimedia mailing list