mplayer video output driver not working

Michael Nottebrock michaelnottebrock at
Thu Nov 25 22:31:07 PST 2004

On Friday, 26. November 2004 07:13, Kevin Smith wrote:
> PS, since xine is working, i ran xine --verbose and noticed that it was
> using the xv output driver, so this is working with xine, but not with
> mplayer -vo xv  [..]    (I tried -vo gl and a bunch of others to no avail.)

The video driver is not likely to be the problem.

Try specifying the device directly (for example mplayer dvd:// 
-dvd-device /dev/acd0c). If you have both ata and atapicam enabled, try both 
the acd device and the cd device (you may have to modify permissions first).

Have you by chance specified a cache in .mplayer/config, or hardframedrop? The 
libmpeg2 decoder doesn't like most of the options - try to 
rename .mplayer/config to something else to make sure you run with defaults. 
If that still doesn't help, try editing /usr/local/share/mplayer/codecs.conf 
and comment out this paragraph completely (prefix each line with a ";"):

videocodec mpeg12
  info "MPEG 1 or 2 (libmpeg2)"
  comment "with postprocessing"
  status working
  format 0x10000001  ; mpeg 1
  format 0x10000002  ; mpeg 2
  driver libmpeg2
  dll "libmpeg2"
  out YV12,I420,IYUV

   ,_,   | Michael Nottebrock               | lofi at
 (/^ ^\) | FreeBSD - The Power to Serve     |
   \u/   | K Desktop Environment on FreeBSD |

More information about the freebsd-multimedia mailing list