nuppelvideo "nuvrec", mplayer: no audio on 5.1-CURRENT?

Chris Shenton chris at
Sun Oct 5 14:11:13 PDT 2003

Running FreeBSD-5.1-CURRENT. Just built fxtv, nuppelvideo, mplayer
from ports cvsupped last night.

I'm pretty new to multimedia on FreeBSD but have been trying to get a
simple cron-based PVR thing going. I've got an tuner card:

  bktr0: <BrookTree 848A> mem 0xde003000-0xde003fff irq 10 at device 20.0 on pci0
  bktr0: Hauppauge Model 56131 E   
  bktr0: Hauppauge WinCast/TV, Philips FR1236 NTSC FM tuner, dbx stereo.

and "fxtv" is working ok with this.  It's output is wired into my EPIA
mobo's soundcard input and fxtv audio appears in "xmix" as "Line". So
far so good.

To grab something off air, I use fxtv to set the channel then quit.  I
then run NuppelVideo's "nuvrec -t 1 outputfilename" to record a minute
of video; no video or audio appears when I do this.  This mostly works
and can be seen if I play it back through "mplayer -vo xv

Unfortunately, there's no audio.  mplayer diagnostic shows it finds
audio, but it's not clear whether it's simply not playing correctly or
if nuvrec recorded a minute of silence.

On a whim I ran nuvrec under sudo.  When this ran, I hear audio coming
from the sound card speakers -- different than when I ran as me.  When
I played the file (as non-root) it played the audio just fine.

So it appears I have to be root to grab audio with nuvrec, does this
make sense? Why? Fxtv doesn't need it...

Subsequent attempts to capture and such sometimes give me trashed
video upon playback (looks like wrong freq) even if the audio's fine.
Other times cause mplayer to crash.

Can anyone clue me in to what I might be doing wrong (e.g., does
nuvrec really need to be run as root?).

Do you have other multimedia apps you prefer for this simple task?
Again, I'm mostly looking for a command-line thing I can invoke from
cron to record a couple shows.


More information about the freebsd-multimedia mailing list