Need help setting up a dedicated audio server

J. Seth Henry jshamlet at
Mon Jul 7 12:43:36 PDT 2003

Guys & Gals,
Sorry of this is a repost. I wasn't subscribed the last time I sent this, 
so I'm not sure if it made it through.

I have been pulling my hair out trying to setup a dedicated audio
server. I've tried NAS, esound and even arts. NAS 1.6 works, until I try
connecting with xmms-nas or mpg123 - at which point it craps out, going
into a lala land from which only a straight out kill -9 will fix. esound
appears to work, but nothing - neither local nor remote - can talk to
it, and I haven't yet managed to get artsd to even try listening to
remote connections.

Here is the goal:
I have a dedicated FreeBSD app server with no sound hardware at all. I
connect via X terminals (specifically, IBM Netstations). I would like to
be able to run xmms from any terminal on the app server, and redirect
the audio to the above audio server.

I have tried the following so far:

For the NAS setup, I ran 'nasd -aa' on the server, and attempted to
connect via the xmms NAS plugin. I have NAS 1.6 and xmms-nas 0.2. When I
connect, xmms appears to play (the time advances), but no audio. The
server is completely hung, and xmms will crash at the end of the current
song. No audio is played at all, not even a few bad samples.

For the esound setup, I ran 'esd -tcp -public' on the server. I put in
the network details in the esound output plugin in xmms. When I try to
play the song, I get a popup box about xmms not being able to open the
sound device. I have esound 0.2.29, and the xmms & xmms esound plugin
are version 1.2.7.

All of this is running under FreeBSD 4.8-REL (both systems). Audio does
work on the server. I can hear the startup beeps when I launch the esd
daemon, and auplay will play wav files across the network to the NAS
server. Xmms-nas also works - I can play audio directly to an IBM
netstation, though I must reduce the rate to 11kHZ, or it gets very

I did notice that for nas, you specify host:0, but I tried that for the
esound driver, and it didn't help. Instead, you seem to specify a port.

Lastly, esdctl does nothing. I can't get it to give any info on either a
local, or remote, esd daemon.

Has anyone done anything like this? Can anyone give me pointers, a link
to a HOWTO, etc?

Seth Henry

More information about the freebsd-multimedia mailing list