FreeBSD 7 and java networking

David Taylor davidt at
Wed Nov 21 08:35:13 PST 2007

On Wed, 2007-11-21 at 15:37 +0100, Andreas Rudisch wrote:
> On Thu, 8 Nov 2007 18:10:56 +0000
> David Taylor <davidt at> wrote:
> > 
> > As it turns out, I'd just noticed the global "WITH_IPV6=yes"
> > that I'd put in /etc/make.conf, and started recompiling java
> > without IPv6 support shortly before you sent that message.
> > I had already tried (both native jdks) with IPV6 turned
> > off in the "make config" menu -- or so I thought -- but
> > my choice was overriden by that forgotten entry.
> > 
> > The IPv6-less jdk works perfectly, now all that remains
> > is to figure out why IPv6 support has stopped working...
> > 
> > I'm fairly sure it worked fine before I switched motherboards
> > and upgraded to 7-CURRENT (now stable, or beta, or whatever).
> I updated from 6.2-release-p8 to 7.0-beta3 and rebuilt all my ports.
> Does Azureus work properly for you? For me it does not upload/download
> anything. I tried jdk15 and jdk16 both with and without IPv6 support.
> Using does not seem to help.
> With FreeBSD 6.2 I had to add the following to libmap.conf to run Azureus:
> [/usr/local/jdk1.6.0/] 
> This does not seem to help either.
> I am using ULE and SMP on an Intel Core2Duo.

Yes, I'm afraid that when azureus started I assumed it was working -- as
some networking was working (RSS feeds, update checks, etc).
jbidwatcher also appeared to work correctly.

But azureus appears to connect to the tracker & peers OK... then not
download any pieces.  So something is not quite right.

David Taylor

More information about the freebsd-java mailing list